Overleg sjabloon:Pagebanner

Uit Wikivoyage
Naar navigatie springen Naar zoeken springen

Caption-probleem[bewerken]

Door recente wijzigingen (bestandsnaam uit Wikidata halen) werkt "caption=" niet meer als geen bestandsnaam is opgegeven en de bestandsnaam dus uit Wikidata is gehaald. --FredTC (overleg) 15 sep 2014 14:12 (CEST)

Captions kunnen alleen in combinatie met een opgegeven bestandsnaam. Anders zou namelijk gebeuren dat je een "caption=" invult en iemand anders vervolgens de afbeelding verandert op Wikidata, waardoor de caption niet meer klopt met de getoonde afbeelding. Globe-trotter (overleg) 15 sep 2014 23:00 (CEST)
Ja, je hebt gelijk. Alleen zie ik dat je toch een wijziging hebt doorgevoerd waardoor de captiontekst weer verschijnt. Betekent dat, dat je iets hebt geregeld waardoor je er makkelijk achter kunt komen of er andere afbeeldingen in Wikidata staan en er een "caption=" is gebruikt? --FredTC (overleg) 16 sep 2014 10:51 (CEST)
Eigenlijk zou de caption in Wikidata moeten. Maargoed, als de caption niet meer klopt, dan moet iemand het maar aanpassen... Globe-trotter (overleg) 16 sep 2014 14:02 (CEST)

TOC-probleem[bewerken]

WV-PagBanBrowsers.png

In bovenstaande afbeelding zijn met drie browsers schermprints gemaakt van een gedeelte van de pagebanner van de pagina Chiang Mai waarbij de drie mogelijke waarden van de parameter box waren ingesteld in {{pagebanner|box=}}. Opmerkelijk is het dat Mozilla de TOC in het geheel niet toont, maar dat de Engelse WV dit wel goed doet (zoals met Chrome). MS-IE geeft in de Engelse WV dezelfde resultaten als in de Nederlandse WV. In Chrome en Mozilla verschijnt overigens wel het beeld van MS-IE voor een fractie van een seconde.


Leesbaarheid TOC in pagebanner met alle varianten van "box="

box= Chrome Mozilla MS-IE
black 100% nvt 10%
grey 100% nvt 100%
white 30% nvt 100%

Conclusie: er moet een oplossing voor het probleem worden gezocht, en zolang deze nog niet is gevonden, moeten er wel leesbare TOC's verschijnen. Uit de tabel blijkt dat Chrome en MS-IE beide een goed leesbare TOT tonen als de defaultwaarde van box grey is. --FredTC (overleg) 17 sep 2014 09:41 (CEST)

Ik heb het voor implementatie getest op alle gangbare browsers. En het draait al zeker een jaar zonder problemen op de Engelstalige WV. Ik denk dat het een lokaal probleem is op jouw computer. Heb je JavaScript uitgeschakeld? De pagebanner werkt alleen als JavaScript aanstaat. Globe-trotter (overleg) 18 sep 2014 19:42 (CEST)
De Android (4.2.2) browser heeft een herkenbare javascript instelling, en die is aangevinkt; toch heeft deze browser (als ik de desktopweergave heb opgevraagd) het zelfde probleem als MS-IE. Voor de browsers op de computer vind ik het lastiger te controleren, maar ik weet dat ik "active content" moest toestaan voor een website met javascript die op een CD staat. Ook een HTTP-website waarvan ik zeker weet dat die javascripts heeft doet het goed, maar de Wiki's draaien met HTTPS en ik kan geen set instellingen vinden die typisch voor HTTPS gelden. Ook lokale html-files met javascript doen het goed.
Ik weet niet hoe het precies is geïmplementeerd, maar ik heb de indruk dat er vóór de TOC eerst iets op het scherm verschijnt (dat bij MS-IE niet verdwijnt) dat vervolgens via een script wordt vervangen door de "mooie TOC". Dat wekt dan inderdaad het vermoeden dat er scripts zijn die niet worden uitgevoerd, maar javascripts worden bij mij wel degelijk uitgevoerd. Zijn er misschien nog andere script-soorten? Mijn MS-IE is op de door mij gemaakte instelling na (voor "active content"), zoals hij op de PC stond toen ik hem uitpakte.
De ondersteunende .CSS en .JS (en ...?) van de Engelse versie moet nog wel verschillen van die van de Nederlandse versie, anders is het verschil tussen Mozilla WV-en (gaat goed) en Mozilla WV-nl (gaat fout) niet te verklaren. Is het mogelijk dat daar waar de verschillen zijn ook de oorzaak kan worden gevonden?
--FredTC (overleg) 19 sep 2014 06:08 (CEST)

Categorisatie van artikels met banners[bewerken]

Ik ben momenteel bezig met het overzetten van banners van enVoyage naar nlVoyage en maak daarnaast extra banners waar deze hier benodigd zijn. Ik ben in dit proces echter op het volgende gelopen:

  • Artikels met banners die vanuit Wikidata geïmporteerd worden (voorbeeld: Schagen), verschijnen nog steeds in Categorie:Wikivoyage:Heeft defaultbanner, ondanks dat de banner van Wikidata wel degelijk geen standaard banner is.
  • Categorisatie verloopt via categorieën met daarin het Wikivoyage: prefix.

Het tweede kan ik zelf makkelijk oplossen, maar ik ben er niet honderd procent zeker dat dit een fout is. Het eerste probleem vereist iets meer studie van de versie van Pagebanner die hier gebruikt wordt. Misschien dat iemand hier bekend genoeg is met het sjabloon om het op te lossen? Bij voorbaat dank :)
-- Wauteurz (overleg) 15 sep 2018 23:57 (CEST)